Jump to content

Custom Search




Welcome to the C-MAX Hybrid Forum


Sign In  Log in with Facebook

Create Account
Welcome to the C-MAX Hybrid Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Here's some member benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create photo albums and post images. . .more!
Click here to create an account now
 
Guest Message by DevFuse

Get you C-MAX Hybrid Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

Who has 3.1.3 Nav and IT WORKS PROPERLY?


  • Please log in to reply
33 replies to this topic

#1 OFFLINE   Jus-A-CMax

Jus-A-CMax

    Brother Jus

  • Moderators
  • 3,246 posts
  • Region:U.S. Pacific Coast
  • LocationSan Fernando, CA
  • My C-MAX's Year:Decline
  • Current Vehicle:SEL

Posted 10 April 2013 - 02:45 AM

Trying to see if there is ANY poster over here with a MFT 3.1.3 that has a working Navigation with NO issue with "floating" triangle or triangle going over houses etc?

 

Also, if you have the TSB 13-1-11 applied and it works, let us know as well.

 

et us know....anyone?


Edited by Jus-A-CMax, 10 April 2013 - 02:47 AM.








Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   otbiker

otbiker

    New Member

  • C-MAX Hybrid Member
  • 25 posts
  • Region:U.S. Southern Plains
  • LocationKerrville TX
  • My C-MAX's Year:2013
  • Current Vehicle:2013 SE

Posted 10 April 2013 - 04:09 AM

Just recently bought the car, but it appears to be OK. The location is accurate and no float. We are on 3.13. Don't know if the TSB was performed. Dealer sez nothing to update at this time.

 

The only issue we're having is inconsistent pairing with our iPhones...

 

Marty in Kerrville



#3 OFFLINE   shaners

shaners

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 127 posts
  • Region:U.S. Great Lakes
  • LocationPA
  • Current Vehicle:2013 C-max SEL

Posted 10 April 2013 - 04:24 AM

3.1.3 and the TSB 13-1-11 done on my car and still having problems...



#4 OFFLINE   TxTom

TxTom

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 52 posts
  • Region:U.S. Southern Plains
  • LocationValleyRanch, TX
  • Current Vehicle:2013 C-Max SEL w/303A

Posted 10 April 2013 - 05:50 AM

Mine has MFT 3.1.3 w/A3 card and Nav has always been spot on. Apparently no need for TSP. Build date 01/07/2013.



#5 OFFLINE   HannahWCU

HannahWCU

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 363 posts
  • Region:U.S. Southern Atlantic
  • LocationHickory, NC
  • My C-MAX's Year:2013
  • Current Vehicle:2014 Ford Focus Electric

Posted 10 April 2013 - 06:18 AM

I have 3.1.3 and have never had issues.  I was in the Dealer for something unrelated to the Nav and they did the TSB 13-1-11 to my car anyway, Still good, no issues.  October 2012 build.



#6 OFFLINE   MikeB

MikeB

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 219 posts
  • Region:U.S. Southern Atlantic
  • LocationAtlanta, GA
  • Current Vehicle:2013 C-Max Energi

Posted 10 April 2013 - 06:38 AM

3.1.3 and had the location error problem until the TSB was applied. After the TSB, problem seems to be resolved.



#7 OFFLINE   CMax

CMax

    New Member

  • C-MAX Hybrid Member
  • 21 posts
  • Region:U.S. Northeast
  • LocationVirginia
  • Current Vehicle:C-Max SEL

Posted 10 April 2013 - 07:27 AM

I have 3.1.3 and was having that issue. I brought my car in for the TSB and they ended up having to replace the GPS Module. Got that done on Friday and haven't had issues so far. Still watching the map most of the time while driving and will report back if I have the issue again. I am hopeful that it is fixed for good.

#8 OFFLINE   rtshinn

rtshinn

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 78 posts
  • Region:U.S. Great Lakes
  • LocationOhio
  • Current Vehicle:Ford C-Max Energi

Posted 10 April 2013 - 08:07 AM

I have 2.15.17 (I think), and had the problem until a GPMS unit was replaced. Now the GPS location is spot on.



#9 OFFLINE   wab

wab

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 927 posts
  • Region:U.S. Southern Plains
  • Locationnorth texas
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SEL 303 with Glass Roof

Posted 10 April 2013 - 08:37 AM

SEL 3.1.3    Build date 1/14/13 no problems.



#10 OFFLINE   asb

asb

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 262 posts
  • Region:Decline
  • LocationFlorida
  • Current Vehicle:cmax se hybrid

Posted 10 April 2013 - 10:43 AM

Mine is fine.

#11 OFFLINE   Adair

Adair

    C-Max Hybrid Member

  • Moderators
  • 1,444 posts
  • Region:U.S. Great Lakes
  • LocationMilan, Michigan
  • Current Vehicle:Ford C-Max Hybrid SEL, 303A, built 11.24.12

Posted 10 April 2013 - 11:13 AM

I have the older version too. I haven't used the GPS much, since I usually travel to places I know, but when I have used it, it's worked fine. Also, the read-out on the screen knows where I am all the time.

 

We'll be driving to a race this weekend and I plan to use it then. If we end up @ Ford Field, and not in the middle of a corn field, we'll be ok.



#12 OFFLINE   Laurel

Laurel

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 1,440 posts
  • Region:Decline
  • LocationCanada
  • My C-MAX's Year:Decline
  • Current Vehicle:SEL

Posted 10 April 2013 - 11:25 AM

We have the SEL 303a --no floating triangle and no TSB as we haven't been in for the first servicing yet.  All is working well.  One incident of having to pair up my phone again and that's it.



#13 OFFLINE   ArizonaEnergi

ArizonaEnergi

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 433 posts
  • Region:U.S. Mountain
  • LocationArizona
  • My C-MAX's Year:2013
  • Current Vehicle:C-MAX Energi 302A

Posted 10 April 2013 - 12:56 PM

It's beginning to look to me as if the problem is a bad batch of GPSM devices.  I'm on 3.1.3 and the dealer confirmed I already had the software from the TSB 13.1.11 installed.  Build date 12/20/12. The floating remains and now I'm thinking I'll go back in with the reported info on the GPMS and get it replaced.  It's annoying to have to educate the dealer on this problem.
 
My video on the problem:
 

Edited by ArizonaEnergi, 28 May 2013 - 08:15 AM.


#14 OFFLINE   joe

joe

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 205 posts
  • Region:U.S. Northeast
  • Locationvirginia
  • My C-MAX's Year:2013
  • Current Vehicle:2013 c-max sel

Posted 10 April 2013 - 01:39 PM

Took C-Max into dealer today to have the gps module replaced.  Called about two hours ago and said that the new module did not fix the problem.  They are talking to Ford to find out why.  GPS has been quirky since we got it in December.

 

UPDATE:  GPS WORKS - YIPEE - my C-Max is now perfect.  We drove around and it stays on track.  No wandering around in the bushes or off road.

 

Here is what the work order says:

"Copied the info from the old GPSM on to the IDS.  Removed the ICP & removed the GPMS.  Installed the new GPMS.  Reinstalled the IPC.  Downloaded the info back into the new GPSM."


Edited by joe, 10 April 2013 - 03:40 PM.


#15 OFFLINE   C-Maxgo

C-Maxgo

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 321 posts
  • Region:U.S. Southern Atlantic
  • LocationRoanoke
  • Current Vehicle:2013 C-Max SEL 301A, Premium Audio & Navigation Package, Built on 1/16/13

Posted 10 April 2013 - 03:40 PM

I'm not having any gps problems. I have 3.1.3 with a build date of January 18th. I haven't taken my car in for any service bulletins.

#16 OFFLINE   Jus-A-CMax

Jus-A-CMax

    Brother Jus

  • Moderators
  • 3,246 posts
  • Region:U.S. Pacific Coast
  • LocationSan Fernando, CA
  • My C-MAX's Year:Decline
  • Current Vehicle:SEL

Posted 10 April 2013 - 06:59 PM

Took C-Max into dealer today to have the gps module replaced.  Called about two hours ago and said that the new module did not fix the problem.  They are talking to Ford to find out why.  GPS has been quirky since we got it in December.

 

UPDATE:  GPS WORKS - YIPEE - my C-Max is now perfect.  We drove around and it stays on track.  No wandering around in the bushes or off road.

 

Here is what the work order says:

"Copied the info from the old GPSM on to the IDS.  Removed the ICP & removed the GPMS.  Installed the new GPMS.  Reinstalled the IPC.  Downloaded the info back into the new GPSM."

 

joe - please keep us all updated. I think u may be onto something here with the GPSM module. Mine was working fine at the start and then started to play up. Looks like there are some good 3.1.3 Navs out there. I'll wait a while before hammering my Galpin Ford about this.

 

Lets see some more....



#17 OFFLINE   C-Maxgo

C-Maxgo

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 321 posts
  • Region:U.S. Southern Atlantic
  • LocationRoanoke
  • Current Vehicle:2013 C-Max SEL 301A, Premium Audio & Navigation Package, Built on 1/16/13

Posted 12 April 2013 - 10:46 AM

Here's an update on my GPS.  Yesterday we took a 300 mile trip that I monitored and here is what I saw.  I usually don't have problems with my navigation until yesterday. I connected my iPod touch via Bluetooth in an attempt to see google map in navigation. I wasn't successful so I turned Bluetooth off on the Itouch. We also had our route programmed in navigation. Then we stopped for lunch and after getting back into the car MTF said to connect a phone. Before we got out of the car I had my phone on and Bluetooth enabled. That's when I realized that MTF has trouble when two Bluetooth devices are connected. I don't know if this affected navigation but it also went crazy and displayed that we were off route but we weren't. After restarting my phone the phone connected and navigation was back to normal.  

 

Later in the trip I noticed that the arrow on the navigation was to the right of the highway we were on and the display read "off route".  I haven't been on enough trips to say that this is a problem because the old highway runs parallel to the one we were on.  Maybe the map is still programed with the old highway.  Are these problems similar to problems that others have been having?



#18 OFFLINE   joe

joe

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 205 posts
  • Region:U.S. Northeast
  • Locationvirginia
  • My C-MAX's Year:2013
  • Current Vehicle:2013 c-max sel

Posted 24 April 2013 - 05:18 PM

Jus-A-Max - So far, we've experienced no problems with the fixed GPS.  We use it everytime we drive to see how its working, and so far, its spot on.


Edited by joe, 27 April 2013 - 06:32 PM.

  • Jus-A-CMax likes this

#19 OFFLINE   Jus-A-CMax

Jus-A-CMax

    Brother Jus

  • Moderators
  • 3,246 posts
  • Region:U.S. Pacific Coast
  • LocationSan Fernando, CA
  • My C-MAX's Year:Decline
  • Current Vehicle:SEL

Posted 24 April 2013 - 06:01 PM

Jus-A-Max - So far, we've experienced not problems with the fixed GPS.  We use it everytime we drive to see how its working, and so far, its spot on.

Thanks Joe - I am about to take my CMax in to have the GPS looked at by Galpin. The 3.5.1 is due really soon but I still want them to check out the GPS unit as you advised. Thanks for the heads up and update - much appreciated  :rockon:



#20 OFFLINE   Bill-N

Bill-N

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 661 posts
  • Region:U.S. Northeast
  • LocationConnecticut
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SEL

Posted 24 April 2013 - 08:46 PM

Jus-A-Max - So far, we've experienced not problems with the fixed GPS.  We use it everytime we drive to see how its working, and so far, its spot on.

 

 

Thanks Joe - I am about to take my CMax in to have the GPS looked at by Galpin. The 3.5.1 is due really soon but I still want them to check out the GPS unit as you advised. Thanks for the heads up and update - much appreciated  :rockon:

 

Just to be clear, are we talking about navigation or GPS?  They are not the same.








Custom Search




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·