Jump to content

Custom Search




Welcome to the C-MAX Hybrid Forum


Sign In  Log in with Facebook

Create Account
Welcome to the C-MAX Hybrid Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Here's some member benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create photo albums and post images. . .more!
Click here to create an account now
 
Guest Message by DevFuse

Get you C-MAX Hybrid Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

Getting GPS Module Replaced!

GPMS GPS

  • Please log in to reply
50 replies to this topic

#21 OFFLINE   ArizonaEnergi

ArizonaEnergi

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 433 posts
  • Region:U.S. Mountain
  • LocationArizona
  • My C-MAX's Year:2013
  • Current Vehicle:C-MAX Energi 302A

Posted 03 May 2013 - 06:33 PM

"GPSM and PMI Module" were replaced today and the GPS is showing EXACTLY where my car is for the first time.  They had it all day, but gave us a rental to use, and they also performed the TSB 13-5-1 DCDC Converter software update.  Part number: CJ5Z-10E893-C; Description: Aerial Asy - G

 

Upon arriving home and plugging it in, the ring did not light up.  I unplugged and plugged back in - still no light.  I unplugged, opened the door and closed it, plugged it back in and the light and fan came on.  Don't know if this is a result of the software update as that would be annoying.  (Update: This is apparently not unknown in an Energi with a depleted battery like ours was.  Typical solution is to start and shutoff the car.  Mine was to open and shut the drivers door.)

 

Overall, glad the GPS is finally working as it should, now only the 3.5.1 left to do when it arrives - pending other issues.


Edited by ArizonaEnergi, 03 May 2013 - 07:58 PM.








Lose this advertisement by becoming a member. Click here to create a free account.


#22 OFFLINE   Jus-A-CMax

Jus-A-CMax

    Brother Jus

  • Moderators
  • 3,246 posts
  • Region:U.S. Pacific Coast
  • LocationSan Fernando, CA
  • My C-MAX's Year:Decline
  • Current Vehicle:SEL

Posted 03 May 2013 - 06:58 PM

Thats great news ArizoneEnergi! I took mine for a long spin today and it performed 99.99%. The 0.01 was due to if offtracking a wee bit as I made a 90 degree turn off a Freeway exit ramp and it soon corrected itself within a second. The old one would just stay there. Other than that, I could not fault it and put that down a mere blip...



#23 OFFLINE   Jus-A-CMax

Jus-A-CMax

    Brother Jus

  • Moderators
  • 3,246 posts
  • Region:U.S. Pacific Coast
  • LocationSan Fernando, CA
  • My C-MAX's Year:Decline
  • Current Vehicle:SEL

Posted 06 May 2013 - 12:19 AM

Second day, took down to Oxnard Beach area and then to Camarillo where the fires were and it was errie. The GPS was 99% effective. A couple of right turns it was thrown off but self corrected within a second. It ain't 100% perfect but it is SO MUCH better than what it was. I am going to take it down to Pacific Palisades tomorrow, lots o-surface tight streets with lots of curvature and all, so it will be interesting. So far, I am very happy with the replacement.


Edited by Jus-A-CMax, 06 May 2013 - 12:20 AM.


#24 OFFLINE   salsaguy

salsaguy

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 1,371 posts
  • Region:U.S. Pacific Coast
  • LocationWhittier, CA
  • Current Vehicle:2012 VW Passat 2.5L SEL Premium

Posted 06 May 2013 - 01:55 AM

this is a problem with many aftermarket gps units as well

its called rubberbanding

look it up

sometimes map data is wrong.did u verify navteq? they have a site to report errors

was there roads below ?

gps thinks you are on other roads. sometimes it doesn't snap back to correct road.

there are settings on some on the dash units like garmin to adjust this

would think new cars



#25 OFFLINE   salsaguy

salsaguy

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 1,371 posts
  • Region:U.S. Pacific Coast
  • LocationWhittier, CA
  • Current Vehicle:2012 VW Passat 2.5L SEL Premium

Posted 06 May 2013 - 02:31 AM

suggest posting this gps issue (and other known cmax issues even mft, etc) on the nhtsa site as a complaint so they gather the data. this has more power to get a fix if there are many people reporting same issue. companies with too many complaints get warnings to resolve

 

http://www.safercar.gov/Vehicle+Owners



#26 OFFLINE   ArizonaEnergi

ArizonaEnergi

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 433 posts
  • Region:U.S. Mountain
  • LocationArizona
  • My C-MAX's Year:2013
  • Current Vehicle:C-MAX Energi 302A

Posted 06 May 2013 - 08:26 AM

When the location indicator trails your car by 100-200' traveling at 45-50 on a straight road for miles, then when you make a turn it turns into whatever area is next to it at the time, but stays closer to the real position when doing 25 and shows the same turn correctly, it's clearly not a mapping error.

 

Replacing the GPSM fixed this problem for now many people with the old map software still in place.  If anyone has the same problem and uses the GPS, I recommend going through the hassle to get the hardware replaced.

sometimes map data is wrong.did u verify navteq? they have a site to report errors

was there roads below ?

gps thinks you are on other roads. sometimes it doesn't snap back to correct road.



#27 OFFLINE   wab

wab

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 927 posts
  • Region:U.S. Southern Plains
  • Locationnorth texas
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SEL 303 with Glass Roof

Posted 06 May 2013 - 10:07 AM

suggest posting this gps issue (and other known cmax issues even mft, etc) on the nhtsa site as a complaint so they gather the data. this has more power to get a fix if there are many people reporting same issue. companies with too many complaints get warnings to resolve

 

http://www.safercar.gov/Vehicle+Owners

 

I thought the NHTSA only worried about safety related issues?

 

I also thought people who follow their GPS/NAV system on to a railroad track are automatically entered in the Annual Darwin Award?

http://eeob.osu.edu/...d-presentations



#28 OFFLINE   WNY

WNY

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 106 posts
  • Region:U.S. Northeast
  • LocationCuba, NY
  • My C-MAX's Year:2013
  • Current Vehicle:F150,Mustang, Escape

Posted 27 November 2015 - 06:30 PM

Resurrecting this thread, are the issues fixed with updated? Mine is 2013 and supposedly had all the updates done (not sure the SIM GPS Card or any NAV updates?) or anything else,

 

My GPS has been dead on since I got the car in Aug and put almost 7000 miles on it. We have taken quite a few trips with it and it's been very accurate.

 

NOW, just tonight it started being about 200-400' off, it was saying I was on a parallel road when I was on the hiway next to it? SOmething just started happening, I haven't done anything else to the car.



#29 OFFLINE   ArizonaEnergi

ArizonaEnergi

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 433 posts
  • Region:U.S. Mountain
  • LocationArizona
  • My C-MAX's Year:2013
  • Current Vehicle:C-MAX Energi 302A

Posted 27 November 2015 - 07:03 PM

My GPS remains rock solid accurate after all updates including self-installing MFM 3.8.  That error sounds like a GPS module failure.  Perhaps a reboot will fix it. (I don't recall how to do that.)  If that doesn't work I would take it in for a warranty fix which may require replacing the module.



#30 OFFLINE   WNY

WNY

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 106 posts
  • Region:U.S. Northeast
  • LocationCuba, NY
  • My C-MAX's Year:2013
  • Current Vehicle:F150,Mustang, Escape

Posted 27 November 2015 - 07:29 PM

Ok, thanks. I'll keep an eye on it. just started today. I don;t what version it has in it

. The Sim Card just says A4. 

 

I got on MyFord/mysync and says the it has the latest updates as of March 2014  Ver. 3.6.2 ?


Edited by WNY, 27 November 2015 - 07:34 PM.


#31 OFFLINE   ArizonaEnergi

ArizonaEnergi

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 433 posts
  • Region:U.S. Mountain
  • LocationArizona
  • My C-MAX's Year:2013
  • Current Vehicle:C-MAX Energi 302A

Posted 27 November 2015 - 07:51 PM

That is the same sim card I have and update I had.  I don't think either have anything to do with the error you are seeing since they have worked for several years for you.


Edited by ArizonaEnergi, 27 November 2015 - 07:51 PM.


#32 OFFLINE   FordIVTteam

FordIVTteam

    C-Max Hybrid Member

  • Official Ford Motor Co.
  • 180 posts
  • Region:Decline
  • LocationDearborn, MI
  • My C-MAX's Year:Decline
  • Current Vehicle:C-MAX

Posted 30 November 2015 - 02:00 PM

Hi WNY, 

Please PM me your VIN and I'll see why you don't have version 3.8 available for download. 

Rebecca



#33 OFFLINE   fbov

fbov

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 1,401 posts
  • Region:U.S. Northeast
  • LocationRochester, NY
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max Hybrid

Posted 30 November 2015 - 02:13 PM

I've had problem that sounds like yours, and it required a module replacement. Look next to "Zoom Out" button for a little GPS icon with a red X. This showed up when mine malfunctioned, which was temporary. I could fix it by removing and reseating the SD card until it was corrected.

GPS not on_sm.jpg

 

TSB14-0037 R/R GPSM fixed it. No issues since, although you can confuse the poor thing if you know where you're going.

 

HAve fun,

Frank

Attached Files


Edited by fbov, 30 November 2015 - 02:17 PM.


#34 OFFLINE   WNY

WNY

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 106 posts
  • Region:U.S. Northeast
  • LocationCuba, NY
  • My C-MAX's Year:2013
  • Current Vehicle:F150,Mustang, Escape

Posted 30 November 2015 - 05:05 PM

Hi WNY, 

Please PM me your VIN and I'll see why you don't have version 3.8 available for download. 

Rebecca

 

Haven't seen the Red X for the GPS or any errors codes. The maps all follow the car, just sometimes it's 200-500' off and shows driving on other roads parallel or a little behind on the highway at the off ramps, etc....

 

PM Sent. 

Thanks!! 

 

I still show these 2 recalls on my MyFord Page for my car. I thought they did all the updates/recalls when I bought the car back in Aug. 

 

  • VIN:
  • FSA Title: 12 VOLT BATTERY TEST AND MODULE SOFTWARE UPDATE
  • Field Service Action Number: 15B04
 
  • VIN:
  • FSA Title: SYNC WITH MYFORD/MYLINCOLN TOUCH - WARRANTY EXTENSION COVERING ACCESSORY PROTOCOL INTERFACE MODULE (APIM)
  • Field Service Action Number: 12M02

Edited by WNY, 30 November 2015 - 05:11 PM.


#35 OFFLINE   Bill-N

Bill-N

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 664 posts
  • Region:U.S. Northeast
  • LocationConnecticut
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SEL

Posted 01 December 2015 - 12:54 AM

 
  • VIN:
  • FSA Title: SYNC WITH MYFORD/MYLINCOLN TOUCH - WARRANTY EXTENSION COVERING ACCESSORY PROTOCOL INTERFACE MODULE (APIM)
  • Field Service Action Number: 12M02

 

 

This is only to document the extended warranty.  There's no actual update associated.



#36 OFFLINE   WNY

WNY

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 106 posts
  • Region:U.S. Northeast
  • LocationCuba, NY
  • My C-MAX's Year:2013
  • Current Vehicle:F150,Mustang, Escape

Posted 01 December 2015 - 01:06 PM

I will check the MySync site and my dealer to see if there's an update to 3.8 or something else wrong with it.

Yesteday and today, seemed to work fine.



#37 OFFLINE   fbov

fbov

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 1,401 posts
  • Region:U.S. Northeast
  • LocationRochester, NY
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max Hybrid

Posted 01 December 2015 - 02:02 PM

Interesting... there is an update available to MyFordTouch/Sync, which recently became available again in a second revision, it would appear. Possible that it could help...

 

And 15B04 is not one I'd skip. 12M04 just makes the MFT update a covered action past the normal warranty period.

 

Frank



#38 OFFLINE   livesmith

livesmith

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 83 posts
  • Region:U.S. Northeast
  • LocationWestern NY
  • My C-MAX's Year:2013
  • Current Vehicle:2013 C-Max Energi with Pano Roof

Posted 18 March 2016 - 08:13 AM

Does anyone have the part number for the GPS module that needs to be replaced?

 

I'm assuming it's the same one for an Energi.

 

Mine is drifting and after a couple days at the dealer I've been told it's not covered under the SYNC warranty and that "there is no problem with the GPS module" based on the fact that they don't see any error codes.  Apparently what it's actually doing is irrelevant.  They are also insisting that I need a $188 map update before anything else.

 

So at this point I'm just trying to find out what the actual item is that needs to be replaced.

 

Thanks!

Levi



#39 OFFLINE   Plus 3 Golfer

Plus 3 Golfer

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 1,934 posts
  • Region:Decline
  • Location"Valley of the Sun" - AZ
  • My C-MAX's Year:2013
  • Current Vehicle:2013

Posted 18 March 2016 - 01:55 PM

Does anyone have the part number for the GPS module that needs to be replaced?

 

I'm assuming it's the same one for an Energi.

 

Mine is drifting and after a couple days at the dealer I've been told it's not covered under the SYNC warranty and that "there is no problem with the GPS module" based on the fact that they don't see any error codes.  Apparently what it's actually doing is irrelevant.  They are also insisting that I need a $188 map update before anything else.

 

So at this point I'm just trying to find out what the actual item is that needs to be replaced.

 

Thanks!

Levi

I believe this is the GPS Module (GPSM) that is located behind the Instrument Panel Cluster (IPC).  Call the dealer parts dept. and ask for the part number of the GPSM to verify?


  • livesmith likes this

#40 OFFLINE   rocolema

rocolema

    New Member

  • C-MAX Hybrid Member
  • 2 posts
  • Region:U.S. Southern Plains
  • LocationUnited States
  • My C-MAX's Year:2014
  • Current Vehicle:C-Max Energi

Posted 18 March 2016 - 02:05 PM

Everyone that has that part replaced has reported that it has fixed their drifting problem (including mine). It was free for me.








Custom Search




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·