Jump to content

Custom Search




Welcome to the C-MAX Hybrid Forum


Sign In  Log in with Facebook

Create Account
Welcome to the C-MAX Hybrid Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Here's some member benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create photo albums and post images. . .more!
Click here to create an account now
 
Guest Message by DevFuse

Get you C-MAX Hybrid Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

Oil Changes


  • Please log in to reply
127 replies to this topic

#121 OFFLINE   ptjones

ptjones

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 3,022 posts
  • Region:U.S. Southern Atlantic
  • LocationNewnan, GA
  • My C-MAX's Year:2013
  • My C-MAX's Color:Ingot Silver
  • Current Vehicle:2013 C-MAX SEL

Posted 22 July 2015 - 04:43 PM

I checked my oil with 10Kmi. on it using Mobil 1 0-30W and it is at the middle of hash mark. Doesn't appear to be using any oil with over 103Kmi on MADMAX. I don't think I have more than 5-6k on the ICE.  :)

 

Paul


Edited by ptjones, 22 July 2015 - 04:51 PM.








Lose this advertisement by becoming a member. Click here to create a free account.


#122 OFFLINE   Adrian_L

Adrian_L

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 675 posts
  • Region:Canada British Columbia
  • LocationVancouver, BC
  • My C-MAX's Year:2013
  • My C-MAX's Color:Tuxedo Black
  • Current Vehicle:2013 SEL

Posted 22 July 2015 - 07:28 PM

Paul, did you ever put a K&N oil filter on yours?   Or did you just stick with the Mastercraft filter?

 

Think I will put Mobil 0W30 in ours this weekend.



#123 OFFLINE   ptjones

ptjones

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 3,022 posts
  • Region:U.S. Southern Atlantic
  • LocationNewnan, GA
  • My C-MAX's Year:2013
  • My C-MAX's Color:Ingot Silver
  • Current Vehicle:2013 C-MAX SEL

Posted 22 July 2015 - 08:30 PM

Paul, did you ever put a K&N oil filter on yours?   Or did you just stick with the Mastercraft filter?

 

Think I will put Mobil 0W30 in ours this weekend.

Yes I used a K&N oil filter. :)

 

Paul



#124 OFFLINE   scottwood2

scottwood2

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 576 posts
  • Region:U.S. Great Lakes
  • LocationMetro Detroit
  • My C-MAX's Year:2014
  • My C-MAX's Color:Tuxedo Black
  • Current Vehicle:2014 C-Max SE, 202A, Winter Package

Posted 23 July 2015 - 08:47 AM

I checked my oil with 10Kmi. on it using Mobil 1 0-30W and it is at the middle of hash mark. Doesn't appear to be using any oil with over 103Kmi on MADMAX. I don't think I have more than 5-6k on the ICE.  :)

 

Paul

Just wondering why you are using 0-30W and not the 0-20W as stated in the manual?



#125 OFFLINE   ptjones

ptjones

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 3,022 posts
  • Region:U.S. Southern Atlantic
  • LocationNewnan, GA
  • My C-MAX's Year:2013
  • My C-MAX's Color:Ingot Silver
  • Current Vehicle:2013 C-MAX SEL

Posted 23 July 2015 - 09:09 AM

I used 0w-30w Mobil 1, trying to decide whether to go to 15kmi or 20kmi. :)

 

Paul



#126 OFFLINE   Tom

Tom

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 201 posts
  • Region:U.S. Southern Atlantic
  • LocationBethesda, Md.
  • My C-MAX's Color:Ice Storm
  • Current Vehicle:C-Max SE

Posted 15 December 2015 - 10:03 AM

My wife was driving our C-Max yesterday and something fell onto the road beneath her -- still partially attached. She pulled off the road and called AAA for a tow to our Ford dealer.  Service writer asked if we had had an oil change recently -- which we had at the dealer.  He speculated that the engine shield had become lose and dropped.

 

Haven't heard back from him as of now but expect to today.

 

I'm bring this to everyone's attention so that the do it your selfers will be careful.  And to get some feedback on any other similar experiences?



#127 OFFLINE   Tom

Tom

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 201 posts
  • Region:U.S. Southern Atlantic
  • LocationBethesda, Md.
  • My C-MAX's Color:Ice Storm
  • Current Vehicle:C-Max SE

Posted 15 December 2015 - 11:01 AM

My wife was driving our C-Max yesterday and something fell onto the road beneath her -- still partially attached. She pulled off the road and called AAA for a tow to our Ford dealer.  Service writer asked if we had had an oil change recently -- which we had at the dealer.  He speculated that the engine shield had become lose and dropped.

 

Haven't heard back from him as of now but expect to today.

 

I'm bring this to everyone's attention so that the do it your selfers will be careful.  And to get some feedback on any other similar experiences?

 

Update:

 

The dealer put a new shield on this morning and was very apologetic about the event. 



#128 OFFLINE   fbov

fbov

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 1,296 posts
  • Region:U.S. Northeast
  • LocationRochester, NY
  • My C-MAX's Year:2013
  • My C-MAX's Color:Ice Storm
  • Current Vehicle:C-Max Hybrid

Posted 15 December 2015 - 11:32 AM

I did my first DIY oil change this Fall. Only one of the 8 screws was missing... it's replacement is in the console. I won't remember it until the next oil change.

 

Frank








Custom Search




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·