Jump to content

Custom Search




Welcome to the C-MAX Hybrid Forum


Sign In  Log in with Facebook

Create Account
Welcome to the C-MAX Hybrid Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Here's some member benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create photo albums and post images. . .more!
Click here to create an account now
 
Guest Message by DevFuse

Get you C-MAX Hybrid Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

Seats too hot!

Heated seats

  • Please log in to reply
12 replies to this topic

#1 OFFLINE   Formerswede

Formerswede

    New Member

  • C-MAX Hybrid Member
  • 1 posts
  • Region:Decline
  • LocationOhio
  • My C-MAX's Year:2013
  • Current Vehicle:C max

Posted 08 February 2019 - 10:28 PM

Has anyone else experienced this? When I turn on my heated front seats to setting 1, they become so hot that I have to turn them off after about 5 minutes. My wife has the same reaction in the passenger seat. I’ve been living with this for 6 years but I’ve finally decided to look into it. It would be nice to just have a low level of heat and just leave it on in the cold.







Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   icanhazc-max

icanhazc-max

    New Member

  • C-MAX Hybrid Member
  • 27 posts
  • Region:Decline
  • LocationUndisclosed
  • My C-MAX's Year:2013
  • Current Vehicle:C-MAX Hybrid

Posted 09 February 2019 - 02:39 AM

From my experience and observation with the heated seats in this car:

 

Level 1: comfortably warm.

Level 2: quickly warms and then HOT, especially when going commando.

Level 3-5: 3rd degree burns.



#3 OFFLINE   homestead

homestead

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 515 posts
  • Region:Decline
  • LocationPacific Northwest
  • Current Vehicle:C-Max Hybrid SEL

Posted 09 February 2019 - 12:53 PM

Setting 1 is too hot for me after 10 minutes but by then the car is warmed up and the heater is putting out heat and I turn off the seat heater.


  • ptjones likes this

#4 OFFLINE   ptjones

ptjones

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 3,744 posts
  • Region:U.S. Southern Atlantic
  • LocationNewnan, GA
  • My C-MAX's Year:2013
  • Current Vehicle:2013 C-MAX SEL

Posted 09 February 2019 - 12:59 PM

I do the same. :)

 

Paul



#5 OFFLINE   fbov

fbov

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 1,448 posts
  • Region:U.S. Northeast
  • LocationRochester, NY
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max Hybrid

Posted 10 February 2019 - 10:17 PM

I had the same problem early on, then I put my knee in the middle of the seat and suddenly, it did't work at all! This was around the time of the seat back recall, so it was all under warranty. The replacement element's been great. I see we're all 2013's; perhaps early elements were too low in resistance?

Frank


  • ptjones likes this

#6 OFFLINE   stolenmoment

stolenmoment

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 80 posts
  • Region:U.S. Northeast
  • LocationBoston
  • My C-MAX's Year:2013
  • Current Vehicle:Maxwell Smart

Posted 11 February 2019 - 08:56 AM

My 2013 is the same way; I used it at 2 for the first time in this recent cold spell (-10F).



#7 OFFLINE   16redsel

16redsel

    New Member

  • C-MAX Hybrid Member
  • 14 posts
  • Region:U.S. Great Lakes
  • LocationOH
  • My C-MAX's Year:2016
  • Current Vehicle:2016 SEL 302A

Posted 13 February 2019 - 01:03 PM

I'm having a different experience in my '16 SEL. Normally turn it between 3 & 4 and it heats up nicely in about a minute. Then I

usually turn it Off.  The nice level of heat lingers long enough until the heat gets going.

 

I can see from experimentation though that it would quickly get way too hot at that setting if left on.

 

 



#8 OFFLINE   cr08

cr08

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 68 posts
  • Region:U.S. Great Lakes
  • LocationColumbus, Ohio
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max E

Posted 13 February 2019 - 01:48 PM

Funny enough I am perfectly happy with the available heat and often leave mine set on 5 any time the temps are about 35 or below. I actually complain about the lack of heat out of the seats in my brother's Crosstrek that only seems to put out about the equivalent of 1 or 2 at best in the C-Max when those are set to their High setting.



#9 OFFLINE   16redsel

16redsel

    New Member

  • C-MAX Hybrid Member
  • 14 posts
  • Region:U.S. Great Lakes
  • LocationOH
  • My C-MAX's Year:2016
  • Current Vehicle:2016 SEL 302A

Posted 15 February 2019 - 05:24 PM

and dammit, there should be a Back heater too - my ass is warm "butt" my back is cold.

IMHO



#10 OFFLINE   icanhazc-max

icanhazc-max

    New Member

  • C-MAX Hybrid Member
  • 27 posts
  • Region:Decline
  • LocationUndisclosed
  • My C-MAX's Year:2013
  • Current Vehicle:C-MAX Hybrid

Posted 16 February 2019 - 01:04 AM

and dammit, there should be a Back heater too - my ass is warm "butt" my back is cold.

IMHO

 

I believe the C-MAX seat heaters include the lumbar. My SEL appears to anyway...



#11 OFFLINE   cr08

cr08

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 68 posts
  • Region:U.S. Great Lakes
  • LocationColumbus, Ohio
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max E

Posted 16 February 2019 - 01:45 AM

Yep. There is a lumbar section to the heated seats.

#12 OFFLINE   homestead

homestead

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 515 posts
  • Region:Decline
  • LocationPacific Northwest
  • Current Vehicle:C-Max Hybrid SEL

Posted 16 February 2019 - 05:12 PM

Mine heats on the bottom seat and middle back area.



#13 OFFLINE   16redsel

16redsel

    New Member

  • C-MAX Hybrid Member
  • 14 posts
  • Region:U.S. Great Lakes
  • LocationOH
  • My C-MAX's Year:2016
  • Current Vehicle:2016 SEL 302A

Posted 27 February 2019 - 08:05 PM

hmm..i'll have to adjust my lumbar support and see if it heats up..may have missed it or not working.








Custom Search




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·