Jump to content

Custom Search




Welcome to the C-MAX Hybrid Forum


Sign In  Log in with Facebook

Create Account
Welcome to the C-MAX Hybrid Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Here's some member benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create photo albums and post images. . .more!
Click here to create an account now
 
Guest Message by DevFuse

Get you C-MAX Hybrid Registered in the official Ford Authorized Registry. More here.


Photo

coolant


  • Please log in to reply
5 replies to this topic

#1 OFFLINE   grege

grege

    New Member

  • C-MAX Hybrid Member
  • 17 posts
  • Region:Decline
  • LocationDC Metro
  • My C-MAX's Year:2017
  • Current Vehicle:C max titanium

Posted 16 July 2018 - 05:43 AM

Two cmax household now.  I've noticed the coolant reservoirs (both the engine and the inverter controller coolant reservoirs) seem to "lose" coolant slowly (the inverter moreso since it seems to have a "pinhole" in the center cap).  How often are people having to add coolant to theirs???  Weird to me that Ford says if at the line for MIN or below, top off coolant...

 

Is coolant consumption that common for the cmaxes in general???

 

Thanks!

Greg









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   SnowStorm

SnowStorm

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 890 posts
  • Region:U.S. Southern Atlantic
  • LocationVirginia
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SE

Posted 16 July 2018 - 06:38 AM

In 160k miles I've added fluid to the inverter twice, I think.  Don't recall about the engine - maybe once.



#3 OFFLINE   Bill-N

Bill-N

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 672 posts
  • Region:U.S. Northeast
  • LocationConnecticut
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SEL

Posted 16 July 2018 - 09:55 AM

My experience is similar; once in 70K  miles.



#4 OFFLINE   grege

grege

    New Member

  • C-MAX Hybrid Member
  • 17 posts
  • Region:Decline
  • LocationDC Metro
  • My C-MAX's Year:2017
  • Current Vehicle:C max titanium

Posted 19 July 2018 - 07:29 AM

Added a couple ounces of distilled water to bring both coolant levels to max and ordered ford prediluted coolant to have on hand should more be needed.  Time will tell...

 

Greg



#5 OFFLINE   ptjones

ptjones

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 3,632 posts
  • Region:U.S. Southern Atlantic
  • LocationNewnan, GA
  • My C-MAX's Year:2013
  • Current Vehicle:2013 C-MAX SEL

Posted 19 July 2018 - 12:28 PM

I don't think I have ever added fluid to either in 205k miles, I have been having FORD do my oil changes about every 30K miles lately so it is possible they may be doing something, but probably not. On my way to FORD to pickup my car from having oil change done and will check levels. :) 

 

Paul 


  • grege likes this

#6 OFFLINE   ptjones

ptjones

    C-Max Hybrid Member

  • C-MAX Hybrid Platinum Member
  • 3,632 posts
  • Region:U.S. Southern Atlantic
  • LocationNewnan, GA
  • My C-MAX's Year:2013
  • Current Vehicle:2013 C-MAX SEL

Posted 23 July 2018 - 01:57 PM

Checked levels all appear the same and they didn't note adding any fluids. :)

 

Paul








Custom Search




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·