Jump to content

Custom Search




Welcome to the C-MAX Hybrid Forum


Sign In  Log in with Facebook

Create Account
Welcome to the C-MAX Hybrid Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Here's some member benefits:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create photo albums and post images. . .more!
Click here to create an account now
 
Guest Message by DevFuse

Get you C-MAX Hybrid Registered in the official Ford Authorized Registry. More here.


Photo
- - - - -

No data on MyFordTouch screen at start up


  • Please log in to reply
6 replies to this topic

#1 OFFLINE   raadsel

raadsel

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 554 posts
  • Region:U.S. Mountain
  • LocationHouston, TX
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SEL

Posted 16 June 2017 - 04:36 PM

I've had a couple of issues with MyFordTouch the last couple of weeks. The first, sometimes when I start my car I get the top and bottom menus for MFT but it will be a completely blank screen in between -- the quadrants and information for Phone, Nav, Entertainment, and Climate won't be there. If I put the car into reverse, so the backup camera comes on, the screen will be correct when it replaces the camera. Also, I typically can touch one of the menus and it will work after that.

 

The other issue, MFT is shutting off after only a minute or two when I shut the car off, after which I'll get the message that it is shutting down to save battery. 

 

With the second issue, I'm guessing that the 12V battery is getting to a point where I need to replace it. Would that also be causing the first issue, or do you think that the system might need to be checked out (and would the recall on the MFT system cover this type of issue)?

 

Also, if it likely is the 12V battery, what is the best way to replace it? First, will I be able to find a suitable replacement locally or will I need to order it over the Internet? Next, for those that have replaced it, how difficult is it to replace? I'm guessing I can find instructions on how to fix it here, and likely on YouTube, I'm mostly curious, since I only have basic tools and skills (such as being able to change oil) how tough I will find it to do.









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   JAZ

JAZ

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 339 posts
  • Region:U.S. Great Lakes
  • LocationDetroit Area
  • My C-MAX's Year:Decline
  • Current Vehicle:2013 C-MAX Hybrid SEL

Posted 16 June 2017 - 05:26 PM

I have always gotten the MFT battery saving shutdown message, even immediately after a 300 mile trip.  I think it's just a precautionary feature.  I just changed the original battery after 4 plus years, even though it was still functioning fine.  



#3 OFFLINE   raadsel

raadsel

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 554 posts
  • Region:U.S. Mountain
  • LocationHouston, TX
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SEL

Posted 16 June 2017 - 06:18 PM

I have always gotten the MFT battery saving shutdown message, even immediately after a 300 mile trip.  I think it's just a precautionary feature.  I just changed the original battery after 4 plus years, even though it was still functioning fine.  

 

It is not that I'm getting the message, it is that I used to get the message after sitting for 10 minutes, or so. Now I'm getting the message after one or two minutes. Just curious if anyone else here has seen that type of decrease? I suppose I ought to get the battery checked.



#4 OFFLINE   homestead

homestead

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 423 posts
  • Region:Decline
  • LocationPacific Northwest
  • Current Vehicle:C-Max Hybrid SEL

Posted 16 June 2017 - 06:31 PM

It is not that I'm getting the message, it is that I used to get the message after sitting for 10 minutes, or so. Now I'm getting the message after one or two minutes. Just curious if anyone else here has seen that type of decrease? I suppose I ought to get the battery checked.

 

I am getting the same decrease from 10 minutes down to one or two, I suspect the last update I had done 6 months ago caused it.



#5 OFFLINE   raadsel

raadsel

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 554 posts
  • Region:U.S. Mountain
  • LocationHouston, TX
  • My C-MAX's Year:2013
  • Current Vehicle:C-Max SEL

Posted 18 June 2017 - 03:21 PM

I'm still wondering if anyone else has had their MFT start up with no information on the screen. I should take a picture next time but it has the menus at the top and bottom and no information in the middle. Any idea what might be going on and if I should get Ford to take a look at it, if it starts happening frequently?



#6 OFFLINE   markd

markd

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 393 posts
  • Region:U.S. Great Lakes
  • LocationUnited States
  • My C-MAX's Year:2014
  • Current Vehicle:c-max sel

Posted 18 June 2017 - 03:39 PM

It happens to me from time to time. It has glitches, that's why they dumped Microsoft.

#7 OFFLINE   jestevens

jestevens

    C-Max Hybrid Member

  • C-MAX Hybrid Member
  • 180 posts
  • Region:U.S. Northeast
  • LocationPennsylvania
  • My C-MAX's Year:2013
  • Current Vehicle:C-MAX SEL Hybrid

Posted 19 June 2017 - 05:57 AM

I've had it sit and spin trying to connect to my phone on Bluetooth.  I've had it get busy and temporarily stop communicating with the display to the right side of the speedo with on the dash ("Navigation Fault" - after having the right side LCD set to navigation) which usually clears itself.  I've had it act like it's on a voice call over hands-free for no good reason that won't hang up no matter how many times you press END CALL.  I've seen it not update track names properly in the CD player.  I've had it reboot and run disk maintenance periodically (that one I'd understand).

 

Having said all of that I actually like the way MFT is laid out in quadrants, etc.  Most of the time it works, it's just soo slooow - bad for driver distraction waiting for the thing to refresh the screen and respond.  They should have upped the hardware specs on the machine probably.  I find a lot of other car infotainment things to be very cluttered.








Custom Search




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy TERMS OF SERVICE ·